[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
[phpBB Debug] PHP Notice: in file [ROOT]/includes/session.php on line 2208: Array to string conversion
www.undertowsoftware.com • View topic - Can't have older versions?

Can't have older versions?

A discussion area for users of Precision Mapping Streets and Traveler v8.0, v8.1 and v9

Can't have older versions?

Postby CraigWY » Wed Dec 21, 2011 9:13 am

Up until now, I used to have v7, v8 and v 8.1 on my system without problems. After I installed version 9, the older versions seem to have gone crazy, they don't work as expected. I checked the FAQs (there is actually nothing there), and called support, but I was told that I need to uninstall all previous versions if I want the program to work correctly.

I have hundreds of programs on my system, from different companies, and I have never encountered this requirement. I don't understand why undertow would do something like this and I don't really care, they must have had their reasons. The question I have is, is there a way to leave the older versions functional on my system, with the ver 9 installed?
User avatar
CraigWY
Casual User
Casual User
 
Posts: 12
Joined: Mon Feb 21, 2011 9:35 am

Re: Can't have older versions?

Postby RWinlow » Mon Dec 26, 2011 10:00 pm

Well, I have found a way to keep and use the old version of the program (8.1) - don't listen to what they tell you. Here is what I did. I didn't delete the old version, just installed v9 in its own folder. Then, when I want to run the 8.1 version, I go to the 8.1 folder and run the command regsvr32.exe /r mappro71.ocx Then I can run the 8.1 version. After I finish, I go to the version 9 folder and run the command regsvr32.exe /r MP2011PM.ocx and I'm ready to run the new version.

It's a kludge, but it does give me the ability to have both versions on my system and run them at will.
User avatar
RWinlow
Senior User
Senior User
 
Posts: 154
Joined: Sat Jan 09, 2010 1:09 am

Re: Can't have older versions?

Postby CraigWY » Tue Dec 27, 2011 12:23 pm

RWinlow wrote:It's a kludge, but it does give me the ability to have both versions on my system and run them at will.

Who cares if it's a kludge? Thank you very much, this is very helpful. Could I set up a windows script to do that automatically? That would be *ideal*!!

I have some instances where I want to run the older version, because I have created a lot of files with it, and don't want to go back and change all of them, so this is awesome.

Thank you again!
User avatar
CraigWY
Casual User
Casual User
 
Posts: 12
Joined: Mon Feb 21, 2011 9:35 am

Re: Can't have older versions?

Postby artmart » Fri Dec 30, 2011 4:38 pm

A little off-topic but I've always wondered how to spell "that word", Kludge. To me, Kludge rhymes with fudge therefore doesn't seem like the right spelling.... how about Kluge which rhymes with "luge" (that downhill skating/skiing sport). Better yet, how about clooge or klooje which then is its own spelling for a word used by computer engineers and users to describe" an arbitrary, undesigned amount of stuff or actions to solve or workaround a feature or problem".

Does anyone else care? Did anyone ever buy the dictionary that documents all the geek-speak words and acronyms that no one else cares about and we can refer to?
Art Martinez
Murrieta, CA
User avatar
artmart
Executive User
Executive User
 
Posts: 840
Joined: Tue Jul 20, 2010 1:43 pm
Location: Murrieta, CA

Re: Can't have older versions?

Postby RWinlow » Sat Dec 31, 2011 6:52 pm

artmart wrote:A little off-topic but I've always wondered how to spell "that word", Kludge. To me, Kludge rhymes with fudge therefore doesn't seem like the right spelling.... how about Kluge which rhymes with "luge" (that downhill skating/skiing sport). Better yet, how about clooge or klooje which then is its own spelling for a word used by computer engineers and users to describe" an arbitrary, undesigned amount of stuff or actions to solve or workaround a feature or problem".


Update your dictionary :-)

kludge or kluge (n. Slang)
1. A system, especially a computer system, that is constituted of poorly matched elements or of elements originally intended for other applications.
2. A clumsy or inelegant solution to a problem.

User avatar
RWinlow
Senior User
Senior User
 
Posts: 154
Joined: Sat Jan 09, 2010 1:09 am

Re: Can't have older versions?

Postby artmart » Mon Jan 02, 2012 5:00 am

Yup, that was it... dictionary needs updating... I found Merriam Webster has kludge or kluge online. I will burn my old paper ones in the next campfire. I still don't like the kludge spelling, but I can leave out the "d" and still be correct.

This is a lot easier to do than trying to figure out how to run several versions of products on the same system. Your reasoning for that makes senseI hope you get that working.
Art Martinez
Murrieta, CA
User avatar
artmart
Executive User
Executive User
 
Posts: 840
Joined: Tue Jul 20, 2010 1:43 pm
Location: Murrieta, CA

Re: Can't have older versions?

Postby RWinlow » Mon Jan 02, 2012 10:30 pm

I created this small script file (batch) to run the old version and then reset for the new one. Make sure you modify any parameters you need for your own setup and your own folders where the program was installed, etc.

@Echo Off
Rem -=-=- Navigate to old version of program
Rem -=-=- It could be whatever older version you want to use
CD "C:\PROGRAM FILES (X86)\PRECISION MAPPING STREETS AND TRAVELER 8.0"
Rem -=-=- Register the previous MAP program tool
REGSVR32 MAPPRO71.OCX
Rem -=-=- Provided you get the message the registration worked, run the program
PMSAT.EXE
Rem -=-=- At this point, change to the folder of the new program
CD "C:\PROGRAM FILES (X86)\PRECISION MAPPING STREETS AND TRAVELER 9.0"
Rem -=-=- Register the New MAP program tool
REGSVR32 MP2011PM.OCX
Rem -=-=- Provided you get the message the registration worked, run the program
PMSAT90.EXE
User avatar
RWinlow
Senior User
Senior User
 
Posts: 154
Joined: Sat Jan 09, 2010 1:09 am


Return to Precision Mapping v8, v8.1 and v9

Who is online

Users browsing this forum: No registered users and 2 guests

cron